CVE-2021-4295
ONC code-validator-api — ONC code-validator-api XML CodeValidatorApiConfiguration.java vocabularyValidationConfigurations xml external entity reference
Description · from the CVE record
A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. The manipulation leads to xml external entity reference. Upgrading to version 1.0.31 is able to address this issue. The name of the patch is fbd8ea121755a2d3d116b13f235bc8b61d8449af. It is recommended to upgrade the affected component. VDB-217018 is the identifier assigned to this vulnerability.
Affected
ProductAffectedFixed inSource
code-validator-api1.0.0–CNA
code-validator-api1.0.1–CNA
code-validator-api1.0.2–CNA
code-validator-api1.0.3–CNA
code-validator-api1.0.4–CNA
code-validator-api1.0.5–CNA
code-validator-api1.0.6–CNA
code-validator-api1.0.7–CNA
code-validator-api1.0.8–CNA
code-validator-api1.0.9–CNA
code-validator-api1.0.10–CNA
code-validator-api1.0.11–CNA
Scores by source
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
VulDB (CNA)5.5CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
VulDB (CNA)5.5CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L