CVE-2021-40865
Apache Software Foundation Apache Storm — Unsafe Pre-Authentication Deserialization In Workers
Description · from the CVE record
An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4
Affected
ProductAffectedFixed inSource
Apache Stormv1.0.0 – < Apache Storm *Apache Storm *CNA
Apache StormApache Storm – < v1.2.4v1.2.4CNA
Scores by source
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H