Paper/Archive/CVE-2021-37404

CVE-2021-37404

Apache Software Foundation Apache Hadoop — Heap buffer overflow in libhdfs native library

Description · from the CVE record

There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected

ProductAffectedFixed inSource
Apache Hadoop2.9.0 to 2.10.1–CNA
Apache Hadoop3.0.0 to 3.1.4–CNA
Apache Hadoop3.2.0 to 3.2.2–CNA
Apache Hadoop3.3.0 to 3.3.1–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References

reflists.apache.org/thread/2h56ztcj3ojc66qzf1nno88vjw9vd4worefsecurity.netapp.com/advisory/ntap-20220715-0007