Paper/Archive/CVE-2021-29476

CVE-2021-29476

WordPress Requests — Insecure Deserialization of untrusted data in rmccue/requests

Description · from the CVE record

Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.

Affected

ProductAffectedFixed inSource
Requests>= 1.6.0, < 1.8.0–CNA

Scores by source

GitHub_M (CNA)9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References

refgithub.com/WordPress/Requests/security/advisories/GHSA-52qp-jpq7-6c54refgithub.com/rmccue/Requests/pull/421