CVE-2020-5211
NetHack NetHack — NetHack AUTOCOMPLETE configuration file option is subject to a buffer overflow
Description · from the CVE record
In NetHack before 3.6.5, an invalid extended command in value for the AUTOCOMPLETE configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.
Affected
ProductAffectedFixed inSource
NetHack< 3.6.5–CNA
Scores by source
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)5.0CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L