Paper/Archive/CVE-2020-4043

CVE-2020-4043

phpMussel phpMussel — Phar unserialization vulnerability in phpMussel

Description · from the CVE record

phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.

Affected

ProductAffectedFixed inSource
phpMussel>= 1.0.0, < 1.6.0–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)7.7CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N

References

refgithub.com/phpMussel/phpMussel/security/advisories/GHSA-qr95-4mq5-r3fhrefgithub.com/phpMussel/phpMussel/issues/167refgithub.com/phpMussel/phpMussel/pull/173refgithub.com/phpMussel/phpMussel/commit/97f25973433921c1f953430f32d3081adc4851a4refgithub.com/phpMussel/phpMussel/security/policy#currently-known-vulnerabilities