Paper/Archive/CVE-2020-11052

CVE-2020-11052

Sorcery Sorcery — Improper Restriction of Excessive Authentication Attempts in Sorcery

Description · from the CVE record

In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.

Affected

ProductAffectedFixed inSource
Sorcery< 0.15.0–CNA

Scores by source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)8.3CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

References

refgithub.com/Sorcery/sorcery/security/advisories/GHSA-jc8m-cxhj-668xrefgithub.com/Sorcery/sorcery/issues/231refgithub.com/Sorcery/sorcery/pull/235refgithub.com/Sorcery/sorcery/commit/0f116d223826895a73b12492f17486e5d54ab7a7