CVE-2020-11020
faye Faye — Authentication and extension bypass in Faye
Description · from the CVE record
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.
Affected
ProductAffectedFixed inSource
Faye>= 0.5.0, < 1.0.4–CNA
Faye>= 1.1.0, < 1.1.3–CNA
Faye>= 1.2.0, < 1.2.5–CNA
Scores by source
NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GitHub_M (CNA)8.5CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N