Paper/Archive/CVE-2019-11580

CVE-2019-11580

Atlassian Crowd — Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability

Description · from the CVE record

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

Affected

ProductAffectedFixed inSource
Crowd2.1.0 – < unspecifiedunspecifiedCNA
Crowdunspecified – < 3.0.53.0.5CNA
Crowd3.1.0 – < unspecifiedunspecifiedCNA
Crowdunspecified – < 3.1.63.1.6CNA
Crowd3.2.0 – < unspecifiedunspecifiedCNA
Crowdunspecified – < 3.2.83.2.8CNA
Crowd3.3.0 – < unspecifiedunspecifiedCNA
Crowdunspecified – < 3.3.53.3.5CNA
Crowd3.4.0 – < unspecifiedunspecifiedCNA
Crowdunspecified – < 3.4.43.4.4CNA

Scores by source

CISA ADP9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CISA ADPSSVCExploitation: active · Automatable: yes · Technical impact: total

References

refjira.atlassian.com/browse/CWD-5388refsecurityfocus.com/bid/108637refpacketstormsecurity.com/files/163810/Atlassian-Crowd-pdkinstall-Remote-Code-Execution.htmlrefcisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-11580kevcisa.gov/known-exploited-vulnerabilities-catalog